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SpanSoft is a member of the Association of Shareware Professionals (ASP). The ASP wants to 
make sure that the shareware principle works for you. If you are unable to resolve a shareware-
related problem with an ASP member by contacting the member directly, the ASP may be able to 
help. The ASP Ombudsman can help you resolve a dispute or problem with an ASP member, but 
does not provide technical support for members' products.

Please write to the ASP Ombudsman at 545 Grover Road, Muskegon, MI 49442-9427 USA, FAX 
616-788-2765 or send a CompuServe message via CompuServe Mail to ASP Ombudsman 
70007,3536.



Using the Help file
To display the "Getting Started" help topic use Help|Getting started from the TreeDraw main 
menu.

The help file is a complete on-line manual for TreeDraw. As well as providing context-sensitive 
help direct from TreeDraw, it contains all the technical information about the program and usage 
tips in an easy-to-use format.

If you are not familiar with using Windows help files, read the 'help on help' information. Do this 
by clicking the left mouse button on 'Help' in the menu above the help file and then on 'How to 
Use Help' in the pull-down menu.

You can get help by either selecting Help|Contents from the main menu or by pressing F1. You 
can also get specific help on whatever task you are carrying out by selecting the Help button in 
the current dialog.



Getting started
This help topic is displayed automatically the first time you start TreeDraw. To come back to this
topic in future sessions use Help|Getting started from the main menu.

This help file is a complete on-line manual for TreeDraw. As well as providing context-sensitive 
help direct from TreeDraw, it contains all the technical information about the program, usage 
tips and details on how to register in an easy-to-use format.

Help
If you are not familiar with using Windows help files, read the 'help on help' information. Do this
by clicking the left mouse button on 'Help' in the menu above and then on 'How to Use Help' in 
the pull-down menu.

You can get help by either selecting Help|Contents from the main menu or by pressing F1. You 
can also get specific help on whatever task you are carrying out by selecting the Help button in 
the current dialog.

Basics
Introducing TreeDraw
Importing a tree file
Formatting a chart
Frequently asked questions



Introducing TreeDraw
TreeDraw is a specialist graphics editor for creating high quality genealogical drop-line charts.

Descendant and ancestral trees may be imported direct from Kith and Kin tree files or from PAF 
GEDCOM files created by other genealogy programs. TreeDraw converts these trees into easily 
edited chart elements which can then be re-formatted and re-arranged before storing and 
printing.

It is now easy to produce perfectly laid out charts and incorporate pictures, diagrams and other 
simple graphics. The charts may be as complex or a simple as you wish.

By importing a combination of descendant and ancestral trees from one or more tree files, it is 
possible to build complex charts which can extend in any direction.

TreeDraw maintains a link between each tree text element and the source field in the original tree
file. This means that you can update each text element automatically to mirror any changes in 
the original file. The tree link for each text element can also be modified manually. This is a 
powerful feature which gives you control over the content and format of the text in the tree.

Additional text elements may be entered manually to provide titles, headings, comments, etc.

As well as text, you can place into the chart simple graphics (lines, boxes, circles) and OLE 
objects like pictures, clip-art, diagrams, etc.

TreeDraw lets you control the size, shape, style, colour and alignment of all chart elements and 
supports colour printing.



Importing a tree file
TreeDraw is designed to produce drop-line trees which are imported into an editable chart so that 
you can re-format them and add extra text and graphics.

TreeDraw will import trees from either Kith and Kin tree (.TRE) files or from PAF compatible 
GEDCOM (.GED) files. If your tree data is maintained by a genealogy program other than Kith and
Kin (eg. Brother's Keeper, Family Scrapbook, PAF, etc), you first need to use that program to 
export your tree data into a GEDCOM file (refer to the program's own documentation for details).

It is recommended that you have the snap-to-grid option on before attempting to import the tree.
This will ensure that the tree elements are aligned correctly and makes it easier to re-format the 
tree afterwards. You can check to see if the grid is on by pressing and holding the left mouse 
button whilst the cursor is over the grid button on the button bar. Drag the cursor away from the 
button before releasing it if you wish to avoid changing the setting.

You can also change various formatting options which will affect the appearance of the tree, 
before importing it. However, the default settings will be suitable.

To start the import either select the Import command from the File menu and then choose a 
Descendant or Ancestral tree or press the Import Descendant or Ancestral tree button on the 
button bar. This will open a file selection dialog where you may enter the name of the tree file to 
import.

The import will then start (press Esc or the Cancel button  in the lower left corner of the main 
window to abort the import). You will see the bargraph display at the bottom of the screen move 
from left to right.

When the bargraph has reached the right hand side, the tree file has been loaded and you will be
presented with the import dialog where you must choose the person who is to be the root of this 
tree.

Having pressed the OK button in the import dialog, TreeDraw will ask (assuming that you had the 
snap-to-grid on before importing) if you want the program to adjust the grid's vertical granularity 
to match that of the import font. Answer Yes. This will ensure that the vertical spacing of the 
snap-to-grid closely matches the line spacing of the font chosen for the names of people in the 
tree.

TreeDraw now draws the tree elements necessary to make up the tree. The tree will appear in 
your chart with small, green squares at the corner of each element. These indicate that the entire
tree is currently selected so that you can move it to a new position if you wish. Click the left 
mouse button with the cursor away from any chart element to deselect the tree.

You can now re-arrange the tree to your desired layout and add more text or graphics.



Formatting a tree
Once you have imported a tree, you will probably want to start moving the various elements 
around to make a more pleasant layout.

First select a view which will enable you to see as much of the tree as necessary.

To move a chart element around (in fact to perform any operation on it), you must first select it. 
Do this by placing the cursor over the chosen element and clicking the left mouse button. You will
see 2 or 4 small, green squares (known as handles) appear around the element indicating that it 
has been selected. Now press and hold the left mouse button over the selected element. The 
cursor shape will change and a dotted outline will appear over the element indicating that you 
have grabbed it. Now simply move the outline to the new location using the mouse and release 
the mouse button to place the element there.

You can do the same thing with more than one element at a time simply by selecting multiple 
elements. Hold down the Shift key as you click on each element in turn or drag a marquee around
the chosen elements to select them all.

If you want to modify the format or style of an imported tree element, you will probably have to 
Ungroup the group it belongs to and then select the chosen element individually. This may be 
necessary where (for example) a particular line of text is too long and you want to break it onto 
several lines using the Word Wrap command.

Once you have arranged the tree to your satisfaction you should save the chart to disk.



File menu
Either From the menu bar select File.
or Press Alt+F.

Menu items
New
Open
Save
Save as
Import
      Descendant tree
      Ancestral tree
      Speed import (command varies)
Print
Page setup
Print setup
Save file settings
Link filenames
Exit

At the bottom of this menu you will see the filenames of the four most recently used chart files. 
Click on any one to open that file quickly.



Edit menu
Either From the menu bar select Edit.
or Press Alt+E.

Menu items
Undo
Cut
Copy
Paste
Paste link
Delete
Select All
Group
Ungroup
Update text
Object

When editing text in the text edit box, the following commands act on the text being edited 
instead of the chart elements: Undo, Cut, Copy, Paste, Delete, Select All.



Format menu
Either From the menu bar select Format.
or Press Alt+T.

Menu items
Font
Text align
Word wrap
Tree link
Line style
Pattern



Align menu
Either From the menu bar select Align.
or Press Alt+A.

Menu items
Send to back
Bring to front
Left
Centre
Right
Top
Middle
Bottom
Space horizontal
Space vertical



Tools menu
Either From the menu bar select Tools.
or Press Alt+L.

Menu items
Pointer
Line
Ellipse
Round rectangle
Rectangle
Text



View menu
Either From the menu bar select View.
or Press Alt+V.

Menu items
Whole area
1/8
1/4
1/2
Normal
2 x



Options menu
Either From the menu bar select Options.
or Press Alt+O.

Menu items
Tool box
Colour palette
Snap to grid
Page breaks
Display objects
Keep aspect ratio
Auto text update
Import fields
Import text replace
Names font
Details font
GEDCOM
Word wrap width
Date format



Using the button bar
The button bar is located just below the menu bar at the top of the main window. Click on a 
button in the picture of the button bar below to find out what it does.

You can display the function of each button in the status bar by pressing and holding the left 
mouse button and then moving the cursor away from the bar before releasing the button.



Opens a chart file from disk.



Saves the current chart to disk. If the chart has been saved previously it will be saved with the 
same name and overwrite the existing file. If the chart is untitled you will be asked to provide a 
file name.



Imports a Descendant tree from a .TRE or .GED file.



Imports an Ancestral tree from a .TRE or .GED file.



Prints the current chart.



Copies the currently selected chart elements to the clipboard and then deletes them.



Copies the currently selected chart elements to the clipboard.



Pastes the contents of the clipboard into the current chart.



Groups the currently selected chart elements into a group.



Ungroups the currently selected chart elements.



Toggles the snap-to grid on or off.



Toggles the page breaks display on or off.



Zooms in to the next viewing scale.



Zooms out to the next viewing scale.



Opens the help file at the contents page.



Undoes the previous editing operation.



The help button opens the on-line help file at a topic relevant to the current dialog.



Starting a new chart
From the File menu select New.

This will first check to see if the current chart needs to be saved and then clear the chart. The 
snap to grid granularities, page setup attributes and Auto Text Update option will be loaded from 
the file settings file TREEDRAW.OP2.



Using the file selection dialog
The file selection dialog is displayed in response to a File|Open, File|SaveAs,    File|Import 
command or pressing the Select File button in the Tree Link dialog or the Link Filenames dialog.

Ensure that the Directory name is correct. The Files list only shows files of the selected type 
within the current directory. It may sometimes be necessary to move to another drive or 
directory, either to find the file you are looking for or to ensure that a new file is written in the 
correct drive or directory. To select a different drive double-click on the drive letter in the 
Directories list (eg. [-a-]). To move through the directory structure double-click on a directory 
name (eg. [treedraw]) to move down a level, or on [..] to move back a level. The Directory 
name will change to show the current directory.

Open or Import:
Select the type of file to open or import. You can open TreeDraw chart (.TDR) files only. You can 
import descendant or ancestral trees from either Kith and Kin tree (.TRE) files or GEDCOM (.GED) 
files. If necessary select the appropriate directory by double-clicking on a directory entry. Select 
the required file from the available files list.

Save as:
Only TreeDraw chart (.TDR) files can be saved. If necessary select the appropriate directory by 
double-clicking on a directory entry. Enter the required file name and select the Ok button.



Opening a chart
Either From the File menu select Open.
or Select a previous file from the bottom of the File menu.
or Press the Open button on the button bar.

This will first check to see if the current chart needs to be saved and then bring up a file selection
dialog.

Use File|Open for loading TreeDraw chart (.TDR) files. Opening a chart file also sets the snap to 
grid granularities, page setup attributes and Auto Text Update options.



Saving a chart
Either From the File menu select Save.
or Press F2.
or Press the Save button on the button bar

The chart will be saved with the name of the file shown in the main window title. If the chart has 
no current filename then the Save As will be used instead.



Saving a chart with a different name
From the File menu select Save as.

This will bring up a file selection dialog.

Use File|SaveAs for saving TreeDraw chart files (.TDR) to disk. If you save a TreeDraw chart file 
with File|SaveAs, the name of the current chart will be changed to the saved filename.



Importing descendant and ancestral trees
You can create a new tree in your chart from two different sources, either a Kith and Kin tree 
(.TRE) file or a PAF compatible GEDCOM (.GED) file.

First, select the Import command from the File menu and then choose a Descendant or Ancestral 
tree or press the Import Descendant or Ancestral tree button on the button bar.

A Descendant tree starts from a chosen (root) person and displays all his/her descendants 
including spouses as a drop-line tree. An Ancestral tree works in the opposite direction. From a 
chosen person, all his/her direct ancestors are displayed.

A file selection dialog will open to let you choose the file from which you wish to import the tree.

If the tree file you choose to import was the last file to be imported during this TreeDraw session, 
it will still be in memory and you will be asked if you want to use the version in memory or load 
the version on disk. This is useful when importing a large GEDCOM file and you want to 
experiment by importing using different tree formats, fonts, etc. By holding the GEDCOM file in 
memory TreeDraw can immediately access the tree data, making for a very fast import. Take care
when you have amended a tree file or GEDCOM file and saved it to disk. The changes will not be 
reflected in the version stored in TreeDraw's memory. You will have to reload the tree file from 
disk to get the current version.

When the tree has loaded, you may select the root person and various options to control the 
content of the imported tree.

Person selection may be done by either entering a code number (digits only, do not enter the P) 
or selecting from the list of people.

Set Person details if you wish to include dates and places for individuals.

Set Marriage details if you wish to include dates and places for families (not available in Ancestral
trees.

Set Group tree elements if you wish to have associated tree elements (such as a person's name 
and details) automatically grouped together. This is very useful later when you will want to move 
the tree elements around.

Set Add statistics if you wish to have a stamp/statistics box added at the bottom of the tree. The 
statistics include the name of the imported tree file and number of people, families and 
generations. The stamp is your personalised mark which may be your name and address or 
whatever information you wish. To modify your stamp, alter the text in the file STAMP.TXT using 
Notepad or a word-processor.

Set Flag duplicates if you wish TreeDraw to check for duplicated branches (eg. where cousins 
have married). "*** DUPLICATE ***" will be added to all people which appear more than once in 
the tree. TreeDraw will also truncate the tree at the duplicated person except on the first 
occurrence so that branches of the tree are not duplicated.

If you set All Generations, every descendant or ancestor will be included. If you require to limit 
the depth of the tree, clear the All Generations box and enter a number in Expand to ... 
generations. Entering 0 will produce a tree with only the root person, 1 will include his/her 
children or parents (depending on the tree type), and so on.

Four formats of Descendant or Ancestral tree are available and the selected layout is displayed 
beside the Extend generations and Align tree options. Select Vertically if you wish children to 
proceed across the page and generations from top to bottom and Horizontally for the opposite 
arrangement. Select Left/Top to justify the tree to the left or top (depending on the Extend 



Generations option) and Centre to produce a centred tree.

After pressing the OK button, if you have the snap-to grid option on, you will be asked if you want
the program to adjust the vertical granularity of the grid to match the Names font size. Replying 
Yes to this will ensure that the tree is correctly spaced and easy to modify afterwards.

When the tree has been drawn, all its elements (and only its elements) will be selected to allow 
you to move the whole tree to a new location in the chart.

TreeDraw maintains a link between each imported text element and the file/field it originated 
from. This allows you to update your tree to match any textual changes in the original tree file 
without having to re-import the tree. You can also modify or lock this link.

See also: Customising imported tree contents
See also: Setting GEDCOM import options
See also: Importing from the same tree file again



Importing from the same tree file again
You can quickly import another tree of the same type (descendant or ancestral) from the 
previously imported Kith and Kin tree or GEDCOM file by using the File|Import menu. If a tree has 
been loaded during the current session of TreeDraw the last command in this menu will give the 
file name and tree type; select the command to import the same again. You can also press F3.

Although the tree file and type will be the same as before, you can choose a different root person 
and import options.



Auto-updating text when opening a file
You can force TreeDraw to update all the linked text in a chart file, immediately that file is 
opened. To do this, set the Auto text update option in the Options menu.

This setting is stored with the chart file.



Saving default file settings
TreeDraw saves the current snap to grid granularities, page setup attributes and Auto Text 
Update options with the current chart file (.TDR) when you use the Save or Save as commands.

You can save the current settings of these options as defaults so that when TreeDraw starts 
running or you use the File|New command, those settings are retrieved.

Set the above options to the values you require and use the Save file settings command from the 
File menu.

This command allows you to define what properties you want each new chart to have. For 
example, you may always use Letter sized paper in your printer so you would save the file 
settings with Letter sized paper selected in the Page setup dialog. That way, every time you start 
a new chart, the page size will automatically be set to Letter.



Setting GEDCOM import options
Use the GEDCOM command from the Options menu to select how TreeDraw reads a GEDCOM file.

The following options can be used. Once set, these options will be used for every tree import from
a GEDCOM file as well as for updating text from a GEDCOM file.

Store extra data in notes:
"Extra data", is GEDCOM data which TreeDraw recognises, but has no corresponding import field 
for. By setting this option any extra data will be added to the appropriate notes. See Supported 
GEDCOM data for a list of recognised extra data.

List extra data in GEDERR.TXT:
By setting this option any extra data will be added to the GEDCOM import error log, GEDERR.TXT.

Convert invalid dates to text:
By setting this option any dates encountered which are invalid (ie. they do not conform to the 
GEDCOM standard date format DD MMM YYYY) are imported but are converted to text.

Display file header and submitter:
The GEDCOM file header and any submitter information will be displayed as it is read from the 
file. Does not apply to text updates.

IBM (DOS) character set code page:
GEDCOM files created with the IBMPC character set (usually from a DOS program) may have been
written using one of the alternative DOS code pages. These pages are generally used in non-
English speaking countries and contain extra characters such as "ñ" to cover the additional 
diacritics used in their language.

You can select one of the following code pages and TreeDraw will convert the incoming extra 
characters into the appropriate ANSI characters for use in Windows. If you are in doubt about 
which code page was used to create the GEDCOM file, assume it was 437 English.

Code pages supported:
437 English
850 Latin I
860 Portuguese
863 Canadian-French
865 Nordic

If the program encounters the end of a GEDCOM file before finding the TRLR record, it assumes 
that the file has been split over more than one disk (or file). You will be prompted to insert the 
disk containing the next file in sequence. GEDCOM files split into several files are named 
<filename>.GED, <filename>.G00, <filename>.G01, etc, where <filename>.GED is the filename
specified for input in the file selection dialog.

Errors encountered during a GEDCOM import are always reported in GEDERR.TXT and you can 
optionally open this file using Windows Notepad after the import.

See also: Supported GEDCOM data
See also: Known incompatibilities





Changing the tree link filenames
Use the Link filenames command from the File menu to change the tree link filenames for an 
entire chart.

When you import a tree from a .TRE or .GED file, TreeDraw maintains a link between each piece 
of text and the source file so that you can automatically update the text in the chart if it changes 
in the source file using Edit|UpdateText.

In some circumstances you may have a chart which contains links to tree files which have been 
moved to a different drive or directory or have had their filename changed. Edit|UpdateText will 
still look for links to the original files and will therefore produce an error.

Using the Link Filenames dialog you can change the name of one or more source files linked to 
the current TreeDraw chart.

Click on the filename in the list which you want to change and then either type the new filename 
in the "New filename" box or click on the Select File button to search for the tree file. When the 
entry in "New filename" is correct you must click on the Change button to change the filename in 
the list. Repeat for any other link files in the list if necessary. Click on the OK button to make the 
changes or Cancel to ignore any changes.

See also: Using the File Selection Dialog
See also: Changing text's link to a tree file



Adding text and simple graphics
Simple graphics:

Place a new simple graphic onto the chart by first selecting the appropriate graphic type from 
either the Tools menu or from the tool box (the cursor will change to ). Press and hold the left 
mouse button to anchor one end of the element then drag the mouse to expand the graphic to 
the right size and shape. Release the mouse button.

Text:

Add a new text element to the chart by selecting the text tool from the Tools menu or from the 
tool box (the cursor will change to ). Click the left mouse button at the position for the new text. 
The text editor at the top of the screen will become active with a flashing vertical line. Key in the 
text you require, using Ctrl+Return to insert line breaks. Press Return or click on the  button to 
finish editing. You can click on the  button to cancel the text element.
See also: Tools



Adding clip-art and photographs
You can easily add clip-art, scanned photographs, bitmaps and other images to your TreeDraw 
chart.

All these items are treated as OLE objects and are handled in basically the same way. For 
instance, to add a clip-art image from the CLIPART.PCX file, follow this procedure.

1) Run the Windows Paintbrush application (or another OLE server painting program which will 
accept .PCX files) and use the File|Open command to load CLIPART.PCX

2) Select the "cut" tool and drag the marquee around the clip-art image you want to use. Now 
use the Edit|Copy command to copy the image to the clipboard. All OLE embedding and linking 
works via the clipboard in this way.

3) Switch to TreeDraw and select the Edit|Paste command or click on the Paste button.

4) Move the cursor into the drawing area and click the left mouse button to position the clip-art 
image.

See also: Working with objects



Working with objects
You may link or embed one or more objects in your TreeDraw chart. The objects may be created, 
played, edited, deleted and copied to the clipboard.

Using the Paste Link or Paste will insert a new object into the chart.

Embedding objects:
Start the application which contains the object to be embedded. Select the object and copy it to 
the clipboard using the Copy command. Switch to TreeDraw and select the Paste command from 
the Edit menu or press Shift+Ins. The cursor will change to the paste cursor.

Linking objects:
Start the application which contains the object to be linked. Select the object and copy it to the 
clipboard using the COPY command. Switch to TreeDraw and select the Paste link command from 
the Edit menu or press Shift+Ins. The cursor will change to the paste cursor. If the Paste link 
command is not available it probably means that the object's source document has not been 
saved or that the source application has not provided the correct data on the clipboard.

Editing and playing objects:
First select the single object which use wish to operate on. The Object command in the Edit menu
will be different for each object type. Select the object command appropriate to the action which 
you wish to carry out. The commands invariably include Edit and sometimes additional 
commands such as Play (eg. for sound objects) are available.
Double-clicking the left mouse button on an object will perform the default action for that 
particular object type. Normally this is Edit but it will vary depending on the object type (eg. Play 
for sound objects).

Copying objects:
Objects can be copied along with other chart elements in the normal way. However, you can copy
an object to the clipboard where it can be pasted to another application, as an object rather than 
a TreeDraw chart. Select a single object from the chart. Select the Copy command from the Edit 
menu or press Ctrl+Ins. This will copy the object to the clipboard. If you want to delete the object 
from the chart at the same time, use the Cut command (or press Shift+Del) instead of Copy.

See also: Turning off OLE object display
See also: Preserving OLE object aspect ratio
See also: Known incompatibilities



Selecting chart elements
Selecting chart elements allows you move, reformat, align, copy and perform other operations, 
on those elements only. There are 2 ways to select chart elements. First, make sure that you have
the Pointer tool selected.

Method 1 - place the cursor over your chosen element and click the left mouse button. You will 
see small, green handles appear to indicate that the element is now selected. You can now select 
(or deselect) additional elements by holding down the shift key while clicking the left mouse 
button.

Method 2 - Drag a marquee around the element(s) you wish to select. Do this by positioning the 
cursor where it is not over any element, press and hold the left mouse button and drag the 
mouse so that the expanding rectangular outline surrounds your chosen elements. Release the 
mouse button.

See also: Selecting all chart elements



Selecting all chart elements
You can select every element in the current chart by using the Select all command from the Edit 
menu or by pressing Ctrl+A.

If you are editing text in the text edit box, this command will operate on the text only.



Moving chart elements
 You can move any existing chart element(s) around on the chart by first selecting them, then 
holding down the left mouse button (the cursor will change to ) and dragging the mouse to the
new location. Release the mouse button to place the elements.



Resizing chart elements
You can resize any existing chart element (except groups) by first selecting it, then placing the 
cursor on one of the green handles which appear around the element. Press and hold the left 
mouse button (the cursor will change to ) then drag the mouse so that the size and shape of 
the element is correct. Release the mouse button.

OLE objects can be forced to preserve their aspect ratio (ie. their size can be changed but not 
their shape) by selecting the Keep aspect ratio command from the Options menu.



Changing text
You can change the text in a text element by selecting the single text element to modify. This 
makes the current text appear in the text editor at the top of the screen. Click on the text in the 
text editor and modify the text as you would in a normal text box. You can use Ctrl+Return to 
insert line breaks. Press Return or click on the  button to finish editing. You can click on the  
button to cancel any changes to the text.

When editing text in the text editor the standard edit commands (undo, cut, copy, paste, delete, 
select all) act on the text in the editor only. Chart elements are not affected.



Cutting to the clipboard
Select the chart element(s) which you wish to copy to the clipboard. Use the Cut command from 
the Edit menu or press Shift+Del or press the Cut button on the button bar.
The selected elements will also be deleted from the chart after copying.

If you are editing text in the text edit box, this command will operate on the text only.

See also: Copy



Copying to the clipboard
Select the chart element(s) which you wish to copy to the clipboard. Use the Copy command from
the Edit menu or press Ctrl+Ins or press the Copy button on the button bar.

The chart elements will be copied to the clipboard in a special format so that they can be pasted 
into the current or other TreeDraw charts. A Windows metafile image of the copied elements will 
also be copied to the clipboard to allow pasting to other applications. If a single text type element
is copied, the text will also be available on the clipboard for pasting into text-based applications. 
If a single object type element is copied, the object itself can then be pasted into other 
applications.

If you are editing text in the text edit box, this command will operate on the text only.

See also: Working with objects



Pasting from the clipboard
You can copy various items from the clipboard to a TreeDraw chart. Use the Paste command from 
the Edit menu or press Shift+Ins or press the Paste button on the button bar to copy in other 
TreeDraw chart elements, text and to embed OLE objects.

The cursor will change to the paste cursor, position the cursor to where you want to place the 
new element(s) and click the left mouse button.

If you are editing text in the text edit box, this command will operate on the text only.

See also: Pasting a link from the clipboard
See also: Working with objects



Pasting a link from clipboard
You can link an OLE object into a chart by using the Paste link command from the Edit menu.

The cursor will change to the paste cursor, position the cursor to where you want to place the 
new element(s) and click the left mouse button.

See also: Pasting from the clipboard
See also: Working with objects



Deleting chart elements
Use the Delete command from the Edit menu or press Del to remove the selected element(s) 
from the chart.

If you are editing text in the text edit box, this command will operate on the text only.



Grouping chart elements together
You can combine several individual chart elements into a single element known as a group. Use 
the Group command from the Edit menu or press Ctrl+G or press the Group button on the button 
bar. The group can then be manipulated in the same way as any individual element, except that 
the size and shape of the group cannot be changed. You can separate the elements at some 
future time.



Ungrouping chart elements
Use the Ungroup command from the Edit menu or press Ctrl+U or press the Ungroup button on 
the button bar to separate chart elements which have been previously grouped together.



Updating text automatically
TreeDraw maintains a link between each imported text element and the file/field it originated 
from. This allows you to update your tree to match any textual changes in the original tree file 
without having to re-import the tree. You can also modify or lock this link.

To update the text in your chart, use the Update text command from the Edit menu or press F9. 
This will open the update dialog.

Set All linked text if you wish to update all the text elements in the chart. If you only want to 
update the text in the currently selected elements, set Selected text.

You can also limit the update to text linked to a particular tree file (instead of all files) by setting 
Links to single tree and choosing a tree file from the list.

You can also get the text updated automatically each time the chart file is opened.

See also: Auto-replacing tree text during import



Undoing the previous editing operation
TreeDraw remembers your previous editing command so that if you decide that was not what you
really wanted to do, you can undo it.

Use the Undo command from the Edit menu or press Alt+BkSp or press the Undo button on the 
button bar.

If you are editing text in the text edit box, this command will operate on the text only.



Setting text font
Use the Font command from the Format menu to change the font for the selected text elements. 
Text may be single elements or embedded within groups. If no elements are selected the default 
font will be changed.

This will bring up a standard font selection dialog. You can then change the typeface, style, size, 
effects and colour of the font. Note that you are not limited to using the listed font sizes.

You can also change a text element's colour by using the colour palette.



Setting text alignment
You can change the alignment of selected text elements by using the Text align command from 
the Format menu. If no text elements are selected the default text alignment will be changed.

Text may be ranged left (ragged right), centred or ranged right (ragged left).



Setting word wrapping
You can force the text in text elements to automatically break lines between words so that the it 
fits neatly into a defined rectangle. Use the Word wrap command from the Format menu.

If no text elements are selected, the default word wrapping will be changed. Any new text 
entered or imported with word wrapping ON will break lines at the width defined in Options|
WordWrapWidth.

With a "wrappable" text element you can adjust the size of the rectangle which the text occupies 
by dragging one of its handles. TreeDraw will re-format the lines of text to fit the rectangle.



Setting the default word-wrap width
With the Format|WordWrap option ON, any new text entered manually or imported as part of a 
tree can be made to line break at a defined width. You set this width using the Word wrap width 
command in the Options menu.

In the "New text wrap width" dialog enter the maximum line length in characters. The actual 
length of each line of text will depend on the font size and the average width of the characters so
the length will not be exactly the number you enter.

See also: Setting word wrapping



Changing text's link to a tree file
TreeDraw lets you modify the link between a text element in your chart and the file and field it 
originated from, if it was imported as part of a tree. You can also use this dialog to create a link 
between a manually entered text element and a tree file.

To change the format of this link first select the single text element you wish to modify then 
select Tree link from the Format menu. This opens the text's Tree link dialog.

Enter the code of the person or family the text is to refer to. Use the format P<number> for 
people or F<number> for families.

Select the file name from the file list. The list contains the names of all files which have been 
used to import trees to the current chart. If you wish to add a new filename to the list, press the 
Select file button.

In the Fields box, enter the format to be used when updating the text. The same field identifiers 
are used both here and in the Import fields dialog. See Customising imported tree contents for 
details of how to format this field. You can add individual fields from the Field Identifiers list 
and/or a selection from the current Field Formats by double clicking on an entry in the Imported 
Data Types list. The Add Field button will add entries from either of the pick lists.

Set Locked if you wish to exclude this text element from any future updates.

TreeDraw will now use the modified link format when you update this text element.

See also: Using the File Selection Dialog
See also: Changing the tree link filenames



Setting the line style
The style and weight of line used by simple graphic chart elements can be altered by using the 
Line style command from the Format menu.    If no elements are selected, the default line style 
will be changed.

Several line types and weights from 1 to 1000 are available.

Dotted
Dashed
Dashed & Dotted
Dashed & 2 Dotted

Hairline The thinnest supported line
Width 1
Width 2
Width 4
Width 6

Other User defined width

The colour of the line may be changed by using the colour palette.



Setting the fill pattern
The style of the filled area enclosed by simple graphic chart elements ellipse, round-cornered 
rectangle and rectangle can be altered by using the Pattern command from the Format menu.    If 
no elements are selected, the default pattern will be changed.

Several styles are available.

Back diagonal
Cross
Diagonal cross
Forward diagonal
Horizontal
Vertical
Hollow (no fill)
Solid

The colour of the pattern (if any) may be changed by using the colour palette.



Setting colours
You can activate the colour palette by using the Colour palette command from the Options menu.

16 colours are available from the palette to be used for defining the colour(s) of chart elements.

Click the left mouse button on the colour to be used for lines and text.
Click the right mouse button on the colour to be used for fills and patterns.

In the example above, black has been selected for the line colour and dark red for the fill colour.

The colour palette may be moved anywhere on the screen.



Choosing a date format
TreeDraw allows you to choose which of several available date formats it should use when 
importing a tree.

The available date formats are:

DD MM YYYY eg. 25 12 1995
DD MMM YYYY eg. 25 Dec 1995
MM DD YYYY eg. 12 25 1995
MMM DD YYYY eg. Dec 25 1995
YYYY MM DD eg. 1995 12 25
YYYY MMM DD eg. 1995 Dec 25
DD MMMM YYYY eg. 25 December 1995
MMMM DD YYYY eg. December 25 1995
WWWW DD MMMM YYYY eg. Monday 25 December 1995
WWWW MMMM DD YYYY eg. Monday December 25 1995

A format definition must also include a separator for the first six formats. In the examples above 
the separator is a space but any character may be used. The separator must be the same 
character in both positions.

eg.    25/12/1995      25-12-1995      25.12.1995

Users who need to use foreign-language versions of month names, etc can modify the entries in 
the TREEDRAW.INI file.

To rename the months, substitute for "January" the appropriate month name. Do the same for 
"February" and so on. Do not modify anything which comes before "=" or is in "[ ]". You can also 
modify the weekday names.

TREEDRAW.INI :

[Months]
1=January
2=February
3=March
4=April
5=May
6=June
7=July
8=August
9=September
10=October
11=November
12=December

[Days]
1=Sunday
2=Monday
3=Tuesday
4=Wednesday
5=Thursday
6=Friday
7=Saturday



Changing the order of chart elements
Chart elements are placed onto the chart in the order in which they are created, ie. the most 
recent goes on top and may overlap other elements.

You can make existing elements come to the front of the chart by selecting one or more elements
and using the Bring to front command from the Align menu or pressing Ctrl+F.

You can make existing elements go to the back of the chart by selecting one or more elements 
and using the Send to back command from the Align menu or pressing Ctrl+B.



Aligning chart elements horizontally
Select two or more chart elements and use one of the following commands from the Align menu.

Left align elements along their left edges
Centre (Ctrl+C) align elements along their centres
Right align elements along their right edges



Aligning chart elements vertically
Select two or more chart elements and use one of the following commands from the Align menu.

Top align elements along their top edges
Middle (Ctrl+M) align elements along their middles
Bottom align elements along their bottom edges



Spacing chart elements evenly
Select three or more chart elements and use one of the following commands from the Align 
menu.

Space horizontal move elements horizontally so that there is equal space between each
Space vertical move elements vertically so that there is equal space between each



Printing a chart
Either Use the Print command from the File menu.
or Press Ctrl+F8 to print the current tree.

The print will commence immediately (press Esc or the Cancel button  in the lower left corner 
of the main window to abort printing) using the currently selected printer, current page setup and
will only print the selected pages.



Selecting pages to print
The pages which TreeDraw will print are defined by a solid red border on the page breaks display.
By default, only the top-left page in the drawing area is selected and so the program will only 
print one page.

You can select more pages to print with the page breaks display on. This involves enlarging the 
print area by moving the cursor to the page where you want to start printing then pressing and 
holding the right mouse button while you drag the cursor to the last page to be printed. Release 
the mouse button and the print area will be shown by the solid red border.

You can select the pages to print at any view setting but it is recommended that you first set the 
view to Whole Area or 1/8. This will allow you to select any page(s).

Note that the page breaks do not change when the Scale to Fit Page option is selected in the 
Page Setup dialog.

See also: Displaying page breaks



Setting page parameters
From the File menu select Page setup.

The page setup dialog allows you to format various features of the layout of printed charts. The 
settings selected here override any similar settings in the printer driver when the chart is printed.

Units of measure:
You may specify margins and page sizes in either inches or millimetres. When you change from 
one to the other, the current values will be converted for you.

Margins:
Enter the measurement for each of the page margins. Note that problems with printouts may be 
encountered when setting small margins. The printer you are using may have a non-printing area
around the edge of the physical page and this may lead to missing or garbled print. If you have 
problems like this, try increasing the size of the margins.

Page size and orientation:
Select the appropriate paper size from the drop down list. You can specify a non-standard size 
(one not listed), by selecting Custom and entering the dimensions of the page in the Width and 
Height fields. Select the orientation you require. Portrait is the normal (tall) orientation, landscape
has the page rotated through 90 degrees (wide).

Print pages:
This determines the order in which pages are printed. Pages are printed from the selected print 
area which may be several pages high and several pages wide. If you want to print the first row 
of pages followed by the second row, etc, set Across then down. If you want to print the first 
column of pages followed by the second column, etc, set Down then across.

Set the Scale to fit page option if you want the entire chart squeezed (or possibly expanded) into 
a single page.

See also: print setup



Selecting a printer
From the File menu select Print setup.

This will display a list of available printers. Select the required printer and if you want to change 
the settings for that printer (paper bin, resolution, number of copies etc), select the setup button 
to open the printer driver's setup dialog. Note that the paper size and orientation are overridden 
during printing by the values in the Page Setup dialog.

See Windows or your printer driver documentation for further details of the setup dialog for 
particular printers.



Zooming in and out
You can zoom in and out of a chart by using the View menu or by clicking on the zoom-in or 
zoom-out button on the button bar.

To view the entire drawing area select Whole area from the View menu.

To zoom in on a particular part of the drawing area, first select a chart element. TreeDraw always 
zooms in to or out from the current selection.

To come back to normal (full-sized) viewing quickly, you can also press F5.



Using the snap-to grid
TreeDraw lets you use a invisible or visible grid to align and place chart elements with precision. 
Use the Snap to grid command in the Options menu to alter the properties of the grid.

You can turn the grid on or off by selecting the Grid on check box.    When the grid is on any 
elements that you create, move or resize will snap to the nearest grid intersection.

You can make the grid visible by setting the Grid visible check box. Making the grid visible will 
slow down the display of the chart.

You can modify the granularity (coarseness) of the grid in both the horizontal and vertical 
direction by entering a new value in the appropriate box. The higher the value the coarser the 
grid.

Turning the grid on does not affect the position of existing elements unless you move or resize 
them.

You can also switch the grid on or off quickly by pressing the Grid button on the button bar.



Displaying page breaks
Use the Page breaks command from the Options menu or the Page Breaks button on the button 
bar to turn the page breaks display on and off.

The joins between pages are shown as dotted red lines. The currently selected print area is 
bordered with a solid red line.



Customising imported tree contents
Prior to importing a descendant or ancestral tree, you can define which fields will go where in the 
tree and what indicators (b., d., m. etc) to use.

You can also get TreeDraw to automatically replace selected text as the tree is imported.

To define the content of the imported tree, use the Import fields command from the Options 
menu.

Each item in the "Imported data type" list represents a component of an imported tree:

Name The name of the root person and spouses
Child's name The name of any child
Person details Date of birth, etc
Marriage details Date and place of marriage, etc
Marriage indicator Used when marriage details not requested

As TreeDraw imports the tree, it formats it as follows. The example shows a left justified, vertical 
descendant tree but the text arrangement is the same for all tree types.

The actual contents of each of these components can be user defined in the "Field format" box. 
Click on an item in the "Imported data type" list and then edit its contents.
The field format may consist of any static text (including line breaks) plus any combination of the 
following field identifiers, used to represent actual fields from the imported tree.

~CODE Person or family code
~NOTE Person or family notes
~FNAM Firstnames
~SNAM Surname
~DBIR Date of birth
~PBIR Place of birth
~DCHR Date of christening
~PCHR Place of christening
~DDEA Date of death
~PDEA Place of death
~DBUR Date of burial
~PBUR Place of burial
~UDF1 User defined field 1
~UDF2 User defined field 2

~DMAR Date of marriage
~PMAR Place of marriage
~DDIV Date of divorce
~PDIV Place of divorce



You can add each of the above identifiers to the end of any text in the Field format box, by 
selecting them from the "Field identifiers" pick list and pressing the Add Field button. 
Alternatively, you may double-click on the identifier in the pick list.

You can also enclose parts of a field format within braces "{ }" to indicate that the enclosed part 
will not be used unless at least one of the field identifiers within the braces produces non-blank 
text. This allows you to stop TreeDraw inserting identifiers like "b." where no birth details actually 
exist.

For example:

Say you want to import a descendant tree containing the person Thomas GORDON, code [P413], 
born 20 May 1781 but has no death details...

"Name": ~CODE ~FNAME ~SNAM
results in: [P413] Thomas GORDON
"Name": ~CODE ~FNAME

~SNAM
results in: [P413] Thomas

GORDON
"Name": ~SNAM, ~FNAM
results in: GORDON, Thomas

"Person details": b. ~DBIR ~PBIR
d. ~DDEA ~PDEA

results in: b. 20 May 1781
d.

"Person details": {b. ~DBIR ~PBIR}{
d. ~DDEA ~PDEA}

results in: b. 20 May 1781

Feel free to experiment with different formats. If you want to reset all formats back to their 
original settings, select the Defaults button.

Each field identifier is a ~ (tilde) followed by 4 characters. If you need to use a tilde as static text,
use ~~ to indicate a single tilde. Similarly, if you want to use { or } as static text, use {{ and }}.

When you are importing a tree from a GEDCOM file you can define which GEDCOM tags should be
associated with the two user defined fields for people. Enter the required tag names in the two 
GEDCOM tag fields. See Supported GEDCOM data for a list of useful tags.

For example: to import a person's occupation from a GEDCOM file containing OCCU tags, you 
would enter OCCU in the User field 1 GEDCOM tag box and modify the Person Details Field Format
to include something like {Occupation: ~UDF1} or {Worked as a ~UDF1}.

TreeDraw uses the default line style and colour for the lines in an imported tree.

See also: Fonts for imported trees
See also: Format line style
See also: Auto-replace imported text



Auto-replacing text during tree import
TreeDraw has the capability to automatically find and replace selected text as it is imported from 
a tree file. This is useful, for instance, where you may have recurring, long place names in your 
tree file which you want to shorten in the TreeDraw chart so as to save space (eg. replacing 
"Clackmannanshire" with "Clacks.").

You can maintain a list of text to replace and replacement text by using the Import text replace 
command from the Options menu to open the Replace Text on Import Dialog.

When adding find/replace text pairs to the list it is important to decide in what order to have 
items in the Replace list. TreeDraw searches an imported text element for all instances of the first
item in the Replace list and carries out the appropriate replacements. The program then proceeds
down through the Replace list in the same way until all replacements have been carried out.

If the Replace list contained, say:
replace    "F/B"    with    "Fredericksberg"    and then
replace    "Frederick"    with    "Fred"

then the imported text "F/B" would be changed first to "Fredericksberg" and then to "Fredsberg", 
clearly not the desired result. Changing the list order to:

replace    "Frederick"    with    "Fred"    and then
replace    "F/B"    with    "Fredericksberg"

produces the replacement "F/B" to "Fredricksberg", the "Frederick" not having been found on the 
first pass.

Click on the Add button to add a new find/replace text pair. This opens the Add Replacement Text 
Dialog. New items added in this way are placed after the currently selected item in the Replace 
list or at the start of the list if no items are selected.

Click on the Edit button to change the text of the currently selected item or double click on the 
list entry.

Click on the Delete button to remove the currently selected item from the Replace list.

If you want the replacements to be carried out at each tree import, set the Use at import check 
box. Similarly, if you want the replacements to be carried out at each text update, set the Use at 
update check box.



Add/Edit replacement text dialog
Enter the text to be replaced and the text it will be replaced with.

You may leave the With field blank but you must have an entry in the Replace field.

Set the Match case check box to make TreeDraw match exactly the upper and lower case letters 
in the Replace field with the imported text, otherwise the case is ignored.



Setting fonts for imported trees
You can specify which fonts will be used for the text in imported trees. To modify the font used for
people's names, use the Names font command from the Options menu. Use the Details font 
command to modify any other details included in the tree.



Turning off OLE object display
Large OLE objects may take a small but noticeable time to display on your screen. This may make
operations such as scrolling appear slow and jumpy. To avoid this you can get TreeDraw to display
a blue, dashed rectangle of the correct size for each object, instead of displaying the object itself.

Use the Display objects command from the Options menu.

Turning off object displays will not affect printing or copying to the clipboard.



Preserving OLE object aspect ratio
Most OLE objects may be resized into any size or shape you wish. With some objects (such as 
scanned photos) this may not be appropriate and you may want to make sure that the shape of 
the photo does not change as you resize it.

You can achieve this by using the Keep aspect ratio command from the Options menu.

When TreeDraw is automatically maintaining the correct aspect ratio of objects, you should drag 
an object handle vertically to change the overall size of the object.



Exiting from TreeDraw
Either From the File menu select Exit.
or Press Alt+F4.

This command will check to see if the current chart needs to be saved before exiting the 
program.



Tools
You must select the appropriate tool before carrying out any actions on chart elements. Tools may
be selected from the Tools menu or from the tool box. Both methods have the same effect. If the 
tool box is not visible on the screen, use the Tool box command from the Options menu to make it
appear.

The tool box may be moved anywhere on the screen.

 Pointer (Ctrl+F10) Use for selecting, moving and resizing existing chart elements.

 Line Use to place a new line onto the chart.

 Ellipse Use to place a new circle or ellipse onto the chart.

 Round rect Use to place a new square or rectangle with rounded corners onto
the chart.

 Rectangle Use to place a new square or rectangle onto the chart.

 Text Use to place a new text element onto the chart.



Line width dialog
Enter a number between 1 and 1000 to set the width of the currently selected chart elements or 
the default line width if no elements are selected.



Keyboard / Mouse key assignments
Keyboard
F1 Help Open the TreeDraw help file at the contents topic
Ctrl+F1 Help search Search for keywords in the TreeDraw help file

F2 Save file Saves the current chart (not available for untitled charts)
F3 Speed import Imports the same type of tree from the previously loaded 

tree file
Alt+F4 Exit Exits TreeDraw
F5 Normal view Zooms to the normal viewing size
F9 Update text Updates the text in the chart to match that in the original file
F10 Pointer Chooses the pointer tool

Ctrl+A Select all Selects all chart elements (or text if editing a text element)
Ctrl+B Send to back Moves the selected elements to the back of the chart
Ctrl+C Centre Aligns the selected elements horizontally on their centres
Ctrl+F Bring to front Moves the selected elements to the front of the chart
Ctrl+G Group Groups the selected elements into a single element
Ctrl+M Middle Aligns the selected elements vertically on their middles
Ctrl+U Ungroup Ungroups a grouped element into its component elements

Alt+BkSp Undo Undoes the previous editing operation
Del Delete Deletes the selected elements (or text if editing a text 

element)
Shift+Del Cut Copies the selected elements to the clipboard and deletes 

them from the chart (or text if editing a text element)
Ctrl+Ins Copy Copies the selected elements to the clipboard (or text if 

editing a text element)
Shift+Ins Paste Pastes the contents of the clipboard into the current chart (or

text if editing a text element)

Mouse
Left Multi-function Manipulates chart elements
Double Left Activate OLE object If the selected element is an OLE object, it is opened for 

editing
Right Select print area If Page Breaks are visible on the screen, use the right mouse 

button to select the pages to print



Version information
This is a list of new features, enhancements and bug fixes which is updated with the release of 
each new version of TreeDraw. Any last minute bug fixes are included here and may not be 
present in the flyers or readme files.

Version 1.2    November 1996

User-defined fields from Kith and Kin can now be imported.
GEDCOM tags may be assigned to the two user-defined fields to import additional data.
Divorce details can now be imported from Kith and Kin and GEDCOM.
GEDCOM input now compatible with "standard" V5.5.
View at 1/8th magnification added.
A word-wrap width may now be set to turn long lines of text (eg. notes) into a block.
New speed import command to import from the previous tree file.
New Link Filenames command changes the tree link filenames for an entire chart.
Page breaks, toolbox and colour palette display settings saved between sessions.
Compatible with Kith and Kin V3.1 .TRE files.
Kith and Kin V3.1+ files with objects are imported faster.
Shape of the toolbox changed. Can now be moved in Win95.
WIN95 fed a blank page at the end of each printout - fixed.
Editing a text element and clicking on the Text Tool caused a crash - fixed.
Long lines were not being printed on some printers - fixed.
The on-screen display was not being reset when using File|New - fixed.
TreeDraw crashed when a Text Update had been done which resulted in an empty text element - 
fixed.

Version 1.11a    June 1996

Help file now includes New Zealand registration point.

Version 1.11    September 1995

Kith and Kin V3.0 release.
Reads Kith and Kin version 3.0 tree files as well as V2.x tree files.
Date Format command and TREEDRAW.INI added to specify output format of dates.
Zoom in/out did not always centre on selected element.
In Page Setup, custom paper sizes were not converted from inches to millimetres correctly.
Custom paper sizes now print correctly.
Scale to fit page option did not work on printers which had different horizontal and vertical 
resolutions selected.



Version 1.1    May 1995

Upgrade release.
All imported trees can now be justified left or centre.
Imported trees can now extend vertically or horizontally.
Spouses details are now inserted into Descendant trees automatically.
Christening and burial details are now imported from GEDCOM files.
Child and Marriage order is now correctly picked up from GEDCOM files.
TreeDraw will now check, flag and truncate duplicated tree branches, eg. where cousins have 
married.
You can now Format|Font on text within groups without having to ungroup them.
Scale to Fit Page is now a Page Setup option. The entire chart can be scaled to fit a single page.
TreeDraw was crashing at 000D:0E0B after a text update was carried out on text elements within 
groups within groups. This has been fixed.
TreeDraw was crashing at 0005:4523 when text elements with the Word Wrap option were 
modified to contain no text. This has been fixed.
The TreeDraw help file is now available in text format as TREEDRAW.TXT for sending straight to 
the printer.
No file conversion required. Will read V1.0x files. WARNING: V1.0x will NOT read V1.1x files.

Version 1.01    September 1994

Bug-fix release.
TreeDraw was occasionally hanging the system during startup on some PCs. This has been fixed.

Version 1.0    August 1994

First release.



OLE error codes
Occasionally TreeDraw will display an error message "OLE operation failed" and give an error 
code of the form <a>@<b>. The <b> number indicates the location in the program where the 
error occurred and is only of use when requesting support from us. The <a> number indicates 
the type of error from the list below and may be helpful in pinpointing the cause of the error.

OLE errors are generally caused by removing an application from your system which you used to 
link or embed an object  into TreeDraw or by opening a chart file created on another PC which 
contains objects which you don't have the source application for. Other causes include installing 
an upgraded OLE server which is not backwards compatible or corruption in the registration 
database.

TreeDraw uses OLE version 1.

The client application is TreeDraw, the server is the program user to link or embed the object.

Possible error codes:

3 The OLE function was called in real mode.
4 Either the OLE DLLs or the server could not allocate or lock memory.
5 An OLE stream error occurred; this is generally caused by a failure in the client 
application's Get or Put callback functions.
6 A non-static object was expected by the OLE libraries.
7 There is critical data missing.
8 An error occurred while drawing the object.
9 The metafile specified is invalid.
10 The client application chose to cancel the metafile drawing.
11 The OLE libraries were unable to obtain the necessary data from the clipboard.
12 The requested format is not available.
13 The object is not valid.
14 An invalid operation occurred.
15 An invalid protocol was specified as part of a parameter to an OLE API.
16 An invalid pointer was used.
17 The objects are not equal.
18 An invalid handle was encountered.
19 An error of unknown cause occurred.
20 An invalid class was specified.
21 An invalid command syntax was specified.
22 The data format requested is not available.
23 An invalid colour palette was specified.
24 This is not a linked object.
25 The client application's document contains objects.
26 An incorrect buffer size was passed to a function that places string information in the 
calling function's buffer.
27 The document name contains an invalid drive letter.
28 The client application failed to establish a connection with a network share on which the 
document is located.
29 An invalid name was passed to the function.
30 The server application failed to load the specified template.
31 The server application failed to create a new document.
32 The server application failed to create an embedded instance for the object.
33 The server application failed to open the document; could also indicate an invalid link.
34 The object is not open for editing.
35 OLECLI.DLL failed to start the server application.
36 The client application failed to establish communication with the server application.
37 An error occurred while terminating the server application.



38 An error occurred in executing a DDE execute command.
39 An error occurred in showing the object.
40 An error occurred in executing a verb; this could also indicate an invalid verb.
41 The server application could not provide the native data for the specified item; this is 

usually because the item was deleted in the client application.
42 A picture item could be missing or the server application doesn't recognise the 

presentation format of the object.
43 The server application doesn't support renaming of the object.
44 The OLE DLLs failed to give the native data to the server application.
45 The server application failed to render the native data.
46 The server application failed to render the presentation data.
47 The client application is trying to block a server application that is already blocked, or the 

client is trying to revoke a blocked server or document.
48 The server application is not registered in the system registration database.
49 The server application is trying to register the same document multiple times.
50 Either the server or client is trying to perform an invalid task.
51 The object is out of date.
52 The client application containing the embedded object doesn't accept updates.
53 An error occurred while trying to update the object in the client application.
54 The server application doesn't understand the format given to its SetData method.
55 The client application is trying to load a static object created in another operating system.



Known incompatibilities
OBJECTS
Some applications which produce objects for embedding or linking, do not provide a picture 
image of the object. In these cases TreeDraw will not be able to embed or link the object into a 
chart in the normal way. You can, however, use the Windows Object Packager to associate an icon
with the object. This will then allow TreeDraw to use the object as normal. See the on-line help in 
Object Packager or your Windows documentation for further details.

GEDCOM
TreeDraw has problems importing GEDCOM files created by Pedigree. Pedigree exports an older 
style of GEDCOM file which has no space character between the cross-reference ids and certain 
tags. You can overcome this problem by editing the GEDCOM file directly using NOTEPAD, a word 
processor or other text editor. Search for the text "@INDI" and "@FAM" and replace them with "@ 
INDI" and "@ FAM" respectively throughout the entire GEDCOM file (do not enter the quote 
marks). Save the file and you will now be able to import it into TreeDraw successfully.



Supported GEDCOM data
TreeDraw supports the PAF (Personal Ancestral File) variation of the GEDCOM (Genealogical Data 
Communication) standard, as used by the majority of genealogical programs. There are some 
quirks in PAF GEDCOM, which make it different from the GEDCOM standard proper, and so there 
are no guarantees that TreeDraw will correctly read GEDCOM files not designed to be read by PAF.
Some enhancements have been made to bring TreeDraw into line with the GEDCOM V5.5 
standard in so far as they do conflict with backwards compatibility.

Fully supported tags: (have corresponding fields in TreeDraw)

Record Tag Description
INDI Person data (individual).

NAME Firstnames and surname. If there is more than one NAME tag for a 
particular person, the last one is regarded as the normal name and prior
ones are regarded as aliases.

SEX Gender, male or female (male is assumed if missing).
BIRT Date and place of birth.
CHR Date and place of christening.
DEAT Date and place of death.
BURI Date and place of burial.
NOTE Notes.
FAMS Family id of which this person is a parent.
FAMC Family id of which this person is a child.

FAM Family data.
HUSB Person id of the father of this family.
WIFE Person id of the mother of this family.
CHIL Person id of a child of this family.
MARR Date and place of marriage.
DIV Date and place of divorce.
NOTE Notes.

Extra data tags:
INDI tags can be imported using user field GEDCOM tags.
These tags may also be inserted in notes.

Record Tag Description
INDI Person data (individual).

REFN Reference number.
TITL Title.
OCCU Occupation.
EDUC Education.
RELI Religion.
NATI Nationality.
CAST Caste.

FAM Family data.
REFN Reference number.

Any other tags encountered in a GEDCOM file are ignored but are reported in the log file 
GEDERR.TXT.

See also: Setting GEDCOM import options



Frequently asked questions
Q I have tried to change the fill pattern of a simple graphic but nothing seems to have 
happened.
A The default fill colour is white so on a white background the pattern will be invisible. Use the
colour palette to change the fill colour.

Q I have selected text from an imported tree to change its font but TreeDraw will only let me 
modify the default font.
A Make sure that the text you have selected is not part of a group element. You can spot this 
easily by looking at the Ungroup button on the button bar. If the button is enabled the element 
you have selected is a group. Select the Ungroup button then re-select the text element you want
to modify.

Q I have added a rectangle around my chart but now all I can see is the rectangle; the chart 
has disappeared.
A The default fill for simple graphics such as a rectangle is solid white. The rectangle you 
have added has been placed on top of all the existing chart elements and since it's opaque it has 
hidden everything else. Use the Send to back command to place the rectangle behind the other 
elements.

Q I have a chart that spans two pages but when I try to print it only the first page is printed.
A TreeDraw allows you to choose which pages you want to print. First, turn on the Page breaks
display then select the required pages using the right mouse button. Now when you print, you 
will get all the pages you requested.

Q I have selected landscape printing on my printer but TreeDraw still prints portrait.
A Set landscape printing in the Page setup dialog. Any settings made here override those in 
Printer setup.

Q I want to edit the death details of someone in an imported tree but when I select that text 
element all I can see in the text edit box is the birth details.
A The death details are in the text edit box but are on the next line. Press the cursor down 
key to move down a line. The text edit box can only display one line of text at a time so you need 
to scroll up and down using the cursor keys.

Q How can I zoom in on a particular part of the drawing area?
A Before zooming in, first select a chart element to zoom in on. TreeDraw will zoom in and 
scroll to the selected element.

Q I want to use a very small font for importing a tree but when I use the Options|Names font 
command the smallest font size available is 8 point.
A You are not restricted to the font sizes supplied in the list. These are just the most 
frequently used sizes, you can actually enter any (supported) font size you like , such as 4 point, 
in the edit portion of the size list (click on the edit box at the top of the list).

Q When I import a large tree extending, say, vertically the data on the right hand side is 
missing. How can I get all the data into the chart?
A TreeDraw has a fixed-size drawing area. If you import too large a tree any data which would 
be placed outside the area is discarded. To make sure that all the data is imported you must 
either reduce the font sizes for names and details or import the tree in smaller chunks and 



connect them together afterwards. To do this either start the import from a root person one or 
more generations down the tree (and do this for as many people as is required to build the whole 
tree) or reduce the "Expand to ... generations" setting.

Q Why can I not get any marriage details in my ancestral tree?
A The "marriage details" option in the Import Ancestral Tree dialog is greyed out (disabled) 
because marriages details cannot be easily positioned in an ancestral tree and so TreeDraw does 
not attempt to include them. Marriage details can be included in a descendant tree.

Q How can I print out the entire help file?
A Print the file TREEDRAW.TXT instead.

Q Why are characters missed out at page breaks when I print to my laser printer?
A Some printers, lasers in particular, cannot print partial characters and so where a character 
is partially off the page, the printer will discard it altogether. You should turn on the Page Breaks 
display and move all the text elements away from the page breaks. This will look better if you are
going to join pages together later.

Q Why do some really long lines appear on the screen but are not printed?
A This is a printer driver problem. Some printer drivers can handle long lines, some cannot. 
Check to make sure you have the most recent version of your printer driver. You may also get 
around the problem by either reducing the output resolution (use File|PrintSetup) or by using two 
shorter lines instead of one long one.



Paste cursor -  Indicates that the paste or paste link command has been selected and you 
must now position the cursor at the point where you want the new element placed, then click the 
left mouse button.



Chart - A chart is a single TreeDraw file which contains various graphic elements. The elements 
of a chart may make up one or more trees.



Tree - A dropline genealogical tree imported from a Kith and Kin or GEDCOM file. Not to be 
confused with a chart which may contain several trees.



Object - A piece of information (typically a drawing, picture, slide, sound etc) which has been 
created by a separate application and which has been embedded in or linked into a chart. You 
can use an object from any application which supports OLE (Object Linking and Embedding).



Linking - Linking an object to a chart involves copying your selected object from another 
application onto the clipboard and then pasting the link into the chart. The primary difference 
between linking and embedding is the location of the actual data for the object. The data for a 
linked object is stored outside the chart file in a separate source document, eg. a .BMP file for 
Paintbrush.



Embedding - Embedding an object in a chart involves copying your selected object from another
application onto the clipboard and then pasting it into the chart. The primary difference between 
embedding and linking is the location of the actual data for the object. The data for an embedded
object is stored inside the chart (.TDR) file.



Chart element - Any of the various constituent parts of a chart. There are several types of 
element: (a) simple graphic - line, ellipse, round-cornered rectangle, rectangle; (b) text; (c) OLE 
object; (d) group - which may include one or more of types a-d.



How to contact us

By mail: Nick J Hunter
SpanSoft
11 Rowan Terrace
COWDENBEATH
Fife      KY4 9JZ
Scotland

By telephone: National:                (01383) 510597
International:    +44 1383 510597
Voice and fax available 24hrs on this number.
If sending a fax ensure that your fax sends a
handshake tone immediately so that our phone
system knows it is not a voice call.
Calls by voice may be answered by machine.

By E-Mail: 100101.1155@compuserve.com
Web page: http://ourworld.compuserve.com/homepages/SpanSoft/

SpanSoft is a member of the ASP.



Registration
TreeDraw is a shareware product. This version has been provided so that you may evaluate its 
features and suitability for a trial period of 30 days without payment. We hope that you enjoy 
using it and that you will find it of use. In the event that you wish to continue using it after 30 
days you must become a registered user.

The registration fee is £20. For this you will receive the latest registered version (without all the 
boring shareware reminders), access to telephone support, periodic notification of future releases
and discounts on upgrades. You will also receive decorative and genealogy-related clip-art for 
pasting into your charts.

Special offer!
Register TreeDraw and Kith and Kin and receive both for just £38..
Find details of Kith and Kin in the Help menu under Other Products.

Click on the most convenient payment method from the following choices.

You can register on-line if you are a CompuServe member.

Alternatively, select from the list below if you live in:

UK

Germany

The Netherlands

USA

Australia

New Zealand

Rest of the World

Only with your financial support will I be able to provide you with upgrades and produce more 
quality software. Without your support I will not be able to do so.
The survival of this program and of the shareware concept in general depends on your honesty.

See also: How to contact us and Terms of use.



Registering in the UK
Select payment method:

Cheque / Postal order / Cash

Credit card (Visa / MasterCard / Eurocard / Access / Delta)



Registering in the USA
Select payment method:

Check (US Dollars)

Credit card (Visa / MasterCard / Amex / Discover)



Registering in the rest of the World
Select the country closest to you from this list:
USA, Australia, New Zealand, Germany, The Netherlands

or select one of these payment methods:

UK funds (Pounds Sterling)

Credit card (Visa / MasterCard / Eurocard / Access / Delta)



Registering on-line via CompuServe
If you are a CompuServe (CIS) member, you can register and pay the registration fee using the 
CompuServe Shareware Registration Service. Payment will be charged to your CompuServe 
account.

Prices ($US):
TreeDraw -
      registration fee $34
      shipping $4
      CIS reg ID: 3200
TreeDraw + Kith and Kin (special offer price)
      registration fees $65
      shipping $4
      CIS reg ID: 3201

Log onto CompuServe in the normal way and enter SWREG using Services|Go in WinCIM or at any
! prompt type GO SWREG. Use the appropriate CIS Registration ID above. Please follow the 
instructions on-screen.

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.

Your registered copy of the latest version of TreeDraw (and Kith and Kin if you order it) will be 
despatched air mail from SpanSoft within 2 working days of your request being entered onto 
CompuServe. Delivery is normally around 1 week to most parts of the world but please allow at 
least 2 weeks.
Prices correct at November 1996 for V1.2 but registration for later releases may be subject to price increases. Please check current 
prices on CIS.



Order - TreeDraw
Please print this order using Print Topic and mail to:

 SpanSoft
11 Rowan Terrace
COWDENBEATH
Fife      KY4 9JZ
Scotland

Please send me the latest registered version of TreeDraw at £20.
Please send me the latest registered versions of TreeDraw and Kith and Kin at £38.
(delete as appropriate)

I enclose a cheque/PO/cash for the registration fee(s) of    £_______
Please make cheques/POs payable to SpanSoft.
Overseas customers please add £2 to cover shipping outside the UK and pay in pounds Sterling
only (notes or UK funds drawn on a UK bank).

Name Mr/Mrs/Miss/Ms_____________________________________

Address _________________________________________________
_________________________________________________
_________________________________________________
_________________________________________________

Postcode ___________________________
Country _________________________________________________

Phone ___________________________
E-mail ___________________________

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.

Prices correct at November 1996 for V1.2 but registration for later releases may be subject to price increases.



Order - TreeDraw
Please print this order using Print Topic and mail to:

 SpanSoft
11 Rowan Terrace
COWDENBEATH
Fife      KY4 9JZ
Scotland

Please send me the latest registered version of TreeDraw at $34.
Please send me the latest registered versions of TreeDraw and Kith and Kin at $65.
(delete as appropriate)

Add $4 shipping & handling.

I enclose a check for    $_________US
Please make cheques payable to SpanSoft and pay in US$.

Name Mr/Mrs/Miss/Ms_____________________________________

Address _________________________________________________
_________________________________________________
_________________________________________________
_________________________________________________

Zipcode ___________________________
Country _________________________________________________

Phone ___________________________
E-mail ___________________________

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.

Prices correct at November 1996 for V1.2 but registration for later releases may be subject to price increases.



Credit Card Order (UK) - TreeDraw
Please print this order using Print Topic and mail to:

SpanSoft
11 Rowan Terrace
COWDENBEATH
Fife      KY4 9JZ
Scotland

or phone or fax with your credit card details:
(01383) 510597

or E-mail with your credit card details:
Internet:    100101.1155@compuserve.com

Please send me the latest registered version of TreeDraw at £20.
Please send me the latest registered versions of TreeDraw and Kith and Kin at £38.
(delete as appropriate)

Please charge my Access/MasterCard/Visa/Eurocard/Delta card with £_________

Name Mr/Mrs/Miss/Ms_____________________________________

Address _________________________________________________
_________________________________________________
_________________________________________________
_________________________________________________

Postcode ___________________________

Phone ___________________________
E-mail ___________________________

Card no. _________________________________________________
Expiry date __________________

Signature _____________________________________

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.
(A separate order form is available for overseas customers)

Prices correct at November 1996 for V1.2 but registration for later releases may be subject to price increases. Name and address 
above must match those of your credit card. We regret that we cannot accept credit card orders for delivery to PO Box numbers.



Credit Card Order (Overseas) - TreeDraw
Please print this order using Print Topic and mail to:

SpanSoft
11 Rowan Terrace
COWDENBEATH
Fife      KY4 9JZ
Scotland

or fax this form to:
+44 1383 510597

Please send me the latest registered version of TreeDraw at £20.
Please send me the latest registered versions of TreeDraw and Kith and Kin at £38.
(delete as appropriate)

Add £2 shipping & handling.

Please charge my Access/MasterCard/Visa/Eurocard/Delta card with £_________ pounds Sterling

Name Mr/Mrs/Miss/Ms_____________________________________

Address _________________________________________________
_________________________________________________
_________________________________________________
_________________________________________________

Postcode ___________________________
Country _________________________________________________

Phone ___________________________
E-mail ___________________________

Card no. _________________________________________________
Expiry date __________________

Signature _____________________________________

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.

Prices correct at November 1996 for V1.2 but registration for later releases may be subject to price increases. Name and address 
above must match those of your credit card. We regret that we cannot accept credit card orders for delivery to PO Box numbers. We 
regret that we cannot accept orders by phone or E-mail from outside the UK since we must receive a valid signature.



Credit Card Order - TreeDraw
Please print this order using Print Topic and mail to:

Public (software) Library
PO Box 35705
Houston
TX 77235-5705
USA

or FAX this form to:
713-524-6398 (for orders only)

or phone with your credit card details:
800-242-4775 or 713-524-6394 (both numbers for orders only : 0700-1800 CST Mon-
Thurs, 0700-1230 CST Fri)

Please send me the latest registered version of TreeDraw at $34 (PsL product number: #11528).
Please send me the latest registered versions of TreeDraw and Kith and Kin at $65 (PsL 
product numbers: #11528 & #11172).
(delete as appropriate)

Add $4 shipping & handling.

Please charge my credit card (Visa/MasterCard/Amex/Discover) with $____ US.

Name Mr/Mrs/Miss/Ms_____________________________________

Address _________________________________________________
_________________________________________________
_________________________________________________
_________________________________________________

Zipcode ___________________________
Country _________________________________________________

Phone ___________________________
E-mail ___________________________

Card no. _________________________________________________
Expiry date __________________

Signature _____________________________________

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.



Any questions about the status of shipment of order, refunds, registration options, product details, technical support, volume 
discounts, dealer pricing, site licenses, etc, must be directed to SpanSoft. To ensure that you get the latest version, PsL will notify us 
the day of your order and we will ship the product direct. Please allow two weeks for delivery. Name and address above must match 
those of your credit card. Prices correct at November 1996 for V1.2 but registration for later releases may be subject to price 
increases.



Order - TreeDraw
Please print this order using Print Topic and mail to:

Budgetware
PO Box 496
Newtown NSW 2042
Australia

or FAX this form with your credit card details to:
(02) 516-4236

or phone with your credit card details:
(02) 519-4233

Please send me the latest registered version of TreeDraw at $46.
Please send me the latest registered versions of TreeDraw and Kith and Kin at $87.
(delete as appropriate)

Add $6 shipping & handling.

I enclose a cheque / money order for $_______ Australian payable to Budgetware.
Please charge my credit card (Visa/MasterCard) with $_____ Australian.
(delete as appropriate)

Name Mr/Mrs/Miss/Ms_____________________________________

Address _________________________________________________
_________________________________________________
_________________________________________________
_________________________________________________

Postcode ___________________________
Country _________________________________________________

Phone ___________________________
E-mail ___________________________

Card no. _________________________________________________
Expiry date __________________

Signature _____________________________________

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.
Any questions about the status of shipment of order, refunds, registration options, product details, technical support, volume 
discounts, dealer pricing, site licenses, etc, must be directed to SpanSoft. To ensure that you get the latest version, Budgetware will 



notify us the day of your order and we will ship the product direct. Please allow two weeks for delivery.    If paying by credit card, 
name and address above must match those of your card. Prices correct at November 1996 for V1.2 but registration for later releases
may be subject to price increases.



Order - TreeDraw
Please print this order using Print Topic and mail to:

Simply Shareware Ltd
PO Box 229
Masterton 5901
New Zealand

or FAX this form with your credit card details to:
(06) 378-9915

or phone with your credit card details:
(06) 378-9916

Please send me the latest registered version of TreeDraw at $46.
Please send me the latest registered versions of TreeDraw and Of that Ilk at $87.
(delete as appropriate)

Add $6 shipping & handling.

I enclose a cheque / money order for $_______ NZ payable to Simply Shareware Ltd.
Please charge my credit card (Visa/MasterCard/Bankcard/Diners/Amex) with $_____ NZ.
(delete as appropriate)

Name Mr/Mrs/Miss/Ms_____________________________________

Address _________________________________________________
_________________________________________________
_________________________________________________
_________________________________________________

Postcode ___________________________
Country _________________________________________________

Phone ___________________________
E-mail ___________________________

Card no. _________________________________________________
Expiry date __________________

Signature _____________________________________

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.
Any questions about the status of shipment of order, refunds, registration options, product details, technical support, volume 
discounts, dealer pricing, site licenses, etc, must be directed to SpanSoft. To ensure that you get the latest version, Simply 
Shareware will notify us the day of your order and we will ship the product direct. Please allow two weeks for delivery.    If paying by 
credit card, name and address above must match those of your card. Prices correct at November 1996 for V1.2 but registration for 



later releases may be subject to price increases.



Bestellung - TreeDraw
Please print this order using Print Topic and mail to:

JDS - Software Jens Driese
Postfach 1269
D-26302 Varel
Deutschland

Tel.: 04451 959195
Fax: 04451 959196
CIS: 100273,2252
BTX: DRIESE#

Bestellung:
[      ] TreeDraw 47,00 DM
[      ] TreeDraw und Kith and Kin 89,00 DM

Porto- und Verpackingskosten (Post) + 5,00 DM

Zuschläge:
Gesamtbetrag =_____ DM

[      ]Verrechnunsscheck liegt bei.
[      ]Lastschrifteinzug:

Ich/wir ermächtige/n die Fa. JDS-Software Jens Driese den Rechnungsbetrag von u.g. Konto 
abzubuchen.

KtoNr: ________________________________      BLZ: __________________
Bank: ________________________________
Die Allgemeinen Geschäftsbedingungen erkenne ich an.

Unterschrift    ___________________________________

Name _____________________________________________
Straße u. Nr. _____________________________________________

_____________________________________________
PLZ + Wohnort _____________________________________________

Tel./Fax ___________________________
E-mail ___________________________

Any questions about the status of shipment of order, refunds, registration options, product details, technical support, volume 
discounts, dealer pricing, site licenses, etc, must be directed to SpanSoft. To ensure that you get the latest version, JDS will notify us 
the day of your order and we will ship the product direct. Please allow two weeks for delivery.    If paying by credit card, name and 
address above must match those of your card. Prices correct at November 1996 for V1.2 but registration for later releases may be 
subject to price increases.



Bestelling - TreeDraw
Druk dit formulier af door gebruik te maken van Print Topic.
Stuur het ingevulde formulier naar:

C.S.D. - Computer Solutions Dorth
Postbus 59
NL-7213 ZH    GORSSEL
Nederland

of, wanneer u gebruik maakt van een Credit Card:
FAX naar 057.549.1222
BEL naar 057.549.4545

Stuur mij de meest recente versie van:
[    ]TreeDraw voor fl.68,-
[    ]TreeDraw en Kith and Kin voor fl.122,-

Alle bedragen zijn inclusief administratie- en verzendkosten en 17,5% BTW.

Bovenstaand bedrag voldoe ik vooruit op de volgende wijze:
[    ] via Postgirorekening nr. 27.47.162, C.S.D., Gorssel
[    ] via bankrekening ABN-Amro nr. 49.85.42.173, C.S.D., Gorssel
[    ] (alleen in Belgie) per bank op rekening BBL-Brussel nr. 310.095.966.533

[    ] per Credit Card: AmEx / Diners / Euro-Master / Visa
Kaart nummer: ________ ________ ________ ________        Geldig tot: ___ / ___
op naam van (indien afwijkend van besteller): ____________________________

Handtekening: ______________________________________

[    ] door bijsluiting van een volledig ingevulde en ondertekende Euro- of PostGiro-cheque.

Naam _________________________________________ (M/V)
Adres _________________________________________________

_________________________________________________
_________________________________________________
_________________________________________________

Postcode _________    _____      Plaats    __________________________
Land _________________________________________________
Telefoon __________________________ (uitsluitend t.b.v. ordercontrole)
E-mail __________________________________

De software wordt geleverd op 3,5" diskette.
Alle vragen betreffende orderstatus, registratieopties, produkt details, technische ondersteuning, site licenses, volume discounts, 
dealer pricing, etc. dient u te richten aan SpanSoft. Om zeker te zijn dat u de laatste versie ontvangt, verwerkt C.S.D. op de dag van 
uw betaling uw bestelling. Het programma wordt rechtstreeks door de auteur aan u verzonden. Levering vindt in principe binnen 2 



weken plaats. Betaalt u per CreditCard, dan dienen de gegevens hierboven overeen te komen met die op de kaart. Prijzen gelden 
voor versie 1.2 (November 1996). Prijswijzigingen voor nieuwere versies voorbehouden.



Terms of use
TRIAL USE LICENCE

TreeDraw is NOT freeware or public domain software, it is shareware.    This software, associated 
on-line help and accompanying documentation are copyright © SpanSoft 1994-1996 and are 
protected by international copyright laws. However, BWCC.DLL is copyright © Borland 
International 1991-93 and the images contained in CLIPART.PCX are (as far as we know) public 
domain.

SpanSoft grants you a limited licence to try out this software on your own system, in your own 
working environment for a limited period of 30 days. If you decide that the software is suitable for
your needs and you wish to continue using it after this time, you must become a registered user 
and pay the appropriate registration fee to SpanSoft. This simply means that you are allowed to 
defer payment for the software until after you have decided that you want it. If, after 30 days, 
you decide that you do not wish to continue using this program you must delete it from your 
system.

You are free (and encouraged) to copy and distribute this version of the software to others on 
condition that you include all the files detailed in the distribution licence below and that you 
adhere to the terms of the distribution licence.

You may not use, copy, rent, lease, sell, modify, decompile, disassemble, otherwise reverse 
engineer, or transfer the licensed program except as provided in this agreement.    Any such 
unauthorised use shall result in immediate and automatic termination of this licence. All rights 
not expressly granted here are reserved by SpanSoft.

By using this software you are agreeing to the terms of this licence. If you do not agree to these 
conditions, delete this software from your computer.

LIMITED DISTRIBUTION LICENCE

You may distribute this version of TreeDraw, completely unaltered and including all the files (as 
listed below), without further permission on condition that:

    1) You identify it as shareware.
    2) You leave all intellectual property (copyright) notices in place.
    3) SpanSoft does not request that you stop distribution.

To distribute in modified form, you must consult the appropriate data record in the included 
VENDINFO.DIZ file, which is hereby incorporated by reference. Any distribution satisfying all the 
distribution requirements expressed in that data record is hereby authorised.

Permission to distribute the TreeDraw package is not transferable, assignable, saleable, or 
franchisable.    Each person or organisation wishing to distribute the package must independently 
satisfy the terms of this limited distribution licence.

SpanSoft may revoke any permissions granted here, by notifying you in writing.    All rights not 
expressly granted here are reserved by SpanSoft.

Complete file list:
        TREEDRAW.EXE TreeDraw program
        TREEDRAW.HLP TreeDraw help file
        TREEDRAW.OPT TreeDraw options
        TREEDRAW.OP2 TreeDraw chart defaults
        TREEDRAW.INI TreeDraw date descriptors
        BWCC.DLL Borland custom class DLL



        SS_DATE.DLL SpanSoft date processing DLL
        CATALOG.HLP SpanSoft product catalogue
        SAMPLE.TRE Sample Kith and Kin tree
        SAMPLE.TDR Sample TreeDraw chart
        STAMP.TXT Auto stamp file
        CLIPART.PCX Clipart graphics images
        FILE_ID.DIZ BBS file description
        VENDINFO.DIZ Vendor / BBS information
        README.TXT User information
        TREEDRAW.TXT TreeDraw help in text format.
        VENDOR.TXT Vendor information

LIMITED WARRANTY

Please read carefully.

THIS SOFTWARE IS PROVIDED FOR EVALUATION ONLY, ON AN "AS IS" BASIS.

SPANSOFT DISCLAIMS ALL WARRANTIES RELATING TO THIS SOFTWARE, WHETHER EXPRESSED OR
IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR 
FITNESS FOR A PARTICULAR PURPOSE. NEITHER SPANSOFT NOR ANYONE ELSE WHO HAS BEEN 
INVOLVED IN THE CREATION, PRODUCTION, OR DELIVERY OF THIS SOFTWARE SHALL BE LIABLE 
FOR ANY INDIRECT, CONSEQUENTIAL OR INCIDENTAL DAMAGES ARISING OUT OF THE USE OR 
INABILITY TO USE SUCH SOFTWARE, EVEN IF SPANSOFT HAS BEEN ADVISED OF THE POSSIBILITY 
OF SUCH DAMAGES OR CLAIMS.

THE PERSON USING THIS SOFTWARE BEARS ALL RISKS AS TO THE QUALITY AND PERFORMANCE 
OF THE SOFTWARE. ALTHOUGH THIS SOFTWARE HAS BEEN EXTENSIVELY TESTED, IT IS YOUR (THE
USER'S) RESPONSIBILITY TO DETERMINE IF IT WILL WORK RELIABLY ON YOUR EQUIPMENT AND IN 
YOUR COMPUTING ENVIRONMENT.

Remember. Always keep up-to-date backup copies of all your data files.




